Please select To the mobile version | Continue to access the desktop computer version
Author: Andor

No wifi after sleep-suspend Ubuntu

[Copy link]

12

Threads

49

Posts

316

Credits

Full Member

Rank: 3Rank: 3

Credits
316
 Author| Post time 2022-11-13 22:30:54 | Show all posts
Edited by Andor at 2022-11-13 23:11
Magister replied at 2022-11-12 02:12
I created a simple /etc/pm/config.d/config containing

HOOK_BLACKLIST="wireless"

But I swapped the wifi card for an Intel AX210 and it works very well but no wifi after suspend. So there is something wrong.

I just tried with your solution but with "iwlwifi" instead as I have another wifi card and it doesn't work so clearly there is something wrong because I have the same card on my laptop and ubuntu and linux mint wake up from suspend just fine. What SER5 do you have? maybe you have a different model.
Reply Support Not support

Use magic Report

12

Threads

49

Posts

316

Credits

Full Member

Rank: 3Rank: 3

Credits
316
 Author| Post time 2022-11-17 19:30:08 | Show all posts
Magister replied at 2022-11-12 02:12
I created a simple /etc/pm/config.d/config containing

HOOK_BLACKLIST="wireless"

Hi, I just tried Fedora 37 with the newest kernel 6.0 and the issue still persist so clearly it's not a liner kernel fault but a BIOS problem, also I need to mentiones that I am using intel AX210 wifi card which is well supported at this point.
Reply Support 1 Not support 0

Use magic Report

0

Threads

3

Posts

68

Credits

Member

Rank: 2

Credits
68
Post time 2022-11-27 10:34:04 | Show all posts
Edited by char6ming at 2022-11-27 10:38
Andor replied at 2022-11-17 19:30
Hi, I just tried Fedora 37 with the newest kernel 6.0 and the issue still persist so clearly it's  ...

same problem in my SER5 PRO, and no solution to fix,  info:
ubuntu 22.04.1 LTS (Jammy Jellyfish),  kernel 5.15.0-53-generic #59-Ubuntu SMP Mon Oct 17 18:53:30 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux


Reply Support Not support

Use magic Report

4

Threads

91

Posts

612

Credits

Senior Member

Rank: 4

Credits
612
Post time 2022-11-29 04:22:07 | Show all posts
I have a 5600H and no problem unloading the module automatically, my PC sleeps multiple times a day.
When the problem occurs, you have to shutdown the SER5, wait a few sec, press and hold power for like 30 seconds to make sure it resets the HW, else nothing will work as long as the HW is not reseted.

Unfortunately it seems the AX210 also has problem with sleep mode!

And whatever distro you have, the mt7921e driver is buggy, a lot in 5.1x and also in 6.xx it seems, so your only way is to unload the module.

If you are using systemd the config may be different to unload a module (I'm using MX21 without systemd)
SER5 5600H 32/500 - MX Linux
Reply Support Not support

Use magic Report

4

Threads

91

Posts

612

Credits

Senior Member

Rank: 4

Credits
612
Post time 2022-11-29 04:29:48 | Show all posts
try with a script, make it executable

$ cat /usr/lib/systemd/system-sleep/remove-mt7921e.sh
#!/bin/bash
[ "$1" = "post" ] && exec /usr/sbin/modprobe mt7921e
[ "$1" = "pre" ] && exec /usr/sbin/modprobe -r mt7921e
exit 0
SER5 5600H 32/500 - MX Linux
Reply Support 1 Not support 0

Use magic Report

2

Threads

12

Posts

74

Credits

Member

Rank: 2

Credits
74
Post time 2022-11-29 08:59:40 | Show all posts
Magister replied at 2022-11-12 02:12
I created a simple /etc/pm/config.d/config containing

HOOK_BLACKLIST="wireless"

hi Magister,
I did create file /etc/pm/config.d/config and put those two lines, but on wake up wifi is still not working. I got the following errors from journalctl:
Nov 28 18:40:43 beelink kernel: ACPI: PM: Waking up from system sleep state S3
Nov 28 18:40:43 beelink kernel: mt7921e 0000:02:00.0: can't change power state from D3cold to D0 (config space inaccessible)
Nov 28 18:40:43 beelink kernel: pci 0000:00:00.2: can't derive routing for PCI INT A
Nov 28 18:40:43 beelink kernel: pci 0000:00:00.2: PCI INT A: no GSI
Nov 28 18:40:43 beelink kernel: [drm] PCIE GART of 1024M enabled.
Nov 28 18:40:43 beelink kernel: [drm] PTB located at 0x000000F400900000
Nov 28 18:40:43 beelink kernel: [drm] PSP is resuming...
Nov 28 18:40:43 beelink kernel: [drm] reserve 0x400000 from 0xf4bf800000 for PSP TMR
Nov 28 18:40:43 beelink kernel: mt7921e 0000:02:00.0: AMD-Vi: Event logged [IO_PAGE_FAULT domain=0x000a address=0x0 flags=0x0020]
Nov 28 18:40:43 beelink kernel: mt7921e 0000:02:00.0: AMD-Vi: Event logged [IO_PAGE_FAULT domain=0x000a address=0x0 flags=0x0020]
....
and there're more errors about mt7921e in the log.
I'm using ubuntu 22.04 with kernel 5.15.0-53-generic on Ser5 5600H box, is there anything I'm missing ? are you using the same linux ?
Reply Support Not support

Use magic Report

2

Threads

12

Posts

74

Credits

Member

Rank: 2

Credits
74
Post time 2022-11-29 10:15:57 | Show all posts
supercharging replied at 2022-11-29 08:59
hi Magister,
I did create file /etc/pm/config.d/config and put those two lines, but on wake up wif ...

Hi, I'm here to answer my own question, ubuntu uses systemd, so create file in /etc/pm/config.d/config will NOT work. on ubuntu, you will need to use the script posted by Magister:
$ cat /usr/lib/systemd/system-sleep/remove-mt7921e.sh
#!/bin/bash
[ "$1" = "post" ] && exec /usr/sbin/modprobe mt7921e
[ "$1" = "pre" ] && exec /usr/sbin/modprobe -r mt7921e
exit 0

And I can confirm this works for me! (ubuntu 22.04 LTS + SER5 5600H)
Reply Support 0 Not support 1

Use magic Report

4

Threads

91

Posts

612

Credits

Senior Member

Rank: 4

Credits
612
Post time 2022-11-29 23:07:25 | Show all posts
supercharging replied at 2022-11-28 22:15
Hi, I'm here to answer my own question, ubuntu uses systemd, so create file in /etc/pm/config.d/co ...

This is super great! Yeah MX does not use systemd, I'm glad the script is working I was not able to test it!
SER5 5600H 32/500 - MX Linux
Reply Support Not support

Use magic Report

0

Threads

3

Posts

68

Credits

Member

Rank: 2

Credits
68
Post time 2022-12-09 20:42:29 | Show all posts
Edited by char6ming at 2022-12-09 21:15
Magister replied at 2022-11-29 04:29
try with a script, make it executable

$ cat /usr/lib/systemd/system-sleep/remove-mt7921e.sh

nice, thank you very much, finally , it works for  me
Reply Support Not support

Use magic Report

12

Threads

49

Posts

316

Credits

Full Member

Rank: 3Rank: 3

Credits
316
 Author| Post time 2022-12-10 18:57:47 | Show all posts
I have swapped intel AX210 wifi card to my laptop and no problems at all with linux mint and AX210 kernel 5.15 LTS, so there is definitelly something wrong with this motherboard firmware that is not friendly with linux
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Sign up

Points Rules

Quick Reply To Top Return to the list