Please select To the mobile version | Continue to access the desktop computer version
View: 118|Reply: 3

GTR5 5900HX Fingerprint Scanner Broke

[Copy link]

1

Threads

2

Posts

21

Credits

Newbie

Rank: 1

Credits
21
Post time 7 day(s) ago | Show all posts |Read mode
My fingerprint login option just disappeared.  The Windows Hello says there is no hardware that is supported.  I'm on Windows 11 I do not recall doing any updates.  I did load a new driver for a USB network adapter, that's it.  I have a Yellow triangle on my Device Manager, USB Hub (one device is not recognized).  In windows settings the fingerprint sign-in option is grayed out.  I have tried going back to a restore point a couple of days back when it was working but still the same.  I'm wondering if the hardware is actually broke?  All my drivers and windows is up to date.  Not sure how to find or get the latest fingerprint scanner driver.
Reply

Use magic Report

0

Threads

97

Posts

351

Credits

Super Moderator

Rank: 8Rank: 8

Credits
351
Post time 7 day(s) ago | Show all posts
Reply Support Not support

Use magic Report

1

Threads

2

Posts

21

Credits

Newbie

Rank: 1

Credits
21
 Author| Post time 7 day(s) ago | Show all posts
Edited by JerryA at 2022-08-05 21:01

SOLVED - It looks like the USB device that appeared under Device Manager USB Universal Serial Bus Controllers with Yellow triangle exclamation mark  saying "can't find device descriptor" WAS my missing fingerprint scanner (Biometric devices was not there anymore).  Appears that the Beelink GTR5 uses an EgisTec Touch Fingerprint Sensor.  Not sure exactly how I solved this problem because I tried a lot of stuff, including going to the EgisTec support and downloading the latest driver.  I tried registry edits.  I tried restoring windows system to prior states with Restore.  I tried everything I could read on Google.  I tried downloading the latest driver on Beelink GTR5 support page but, I did not run that.  I did not use the link provided above.  I unpacked the latest driver from EgisTec support and manually force loaded the driver for that.  The latest driver seems to have a 2022 date.  That did not work either.  In the end, I did have the whole original operating system on an old NVME SSD drive.   I swapped SSD's and booted off the old OS and at least the Hello fingerprint sign-in option was back, so I knew it was not broken hardware/reader.  I found all the original EgisTec drivers in C: drive /WIndows /System32 and copied them to a USB stick.  Put the new NVME SSD back in.  Plugged the USB stick back in, and booted/restatred the PC and, don't know, maybe it automatically found the drivers on the USB stick but, everything was back to normal.  The driver there now shows 6/15/2020 version 3.6.2.1 and that is the original and that seems to be working.
Reply Support Not support

Use magic Report

1

Threads

6

Posts

45

Credits

Newbie

Rank: 1

Credits
45
Post time 4 day(s) ago | Show all posts
Do you have a link to the EgisTec driver you used? I'm having real issues with my own fingerprint scanner, and this would be a last roll of the dice before it goes back for replacement......
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Sign up

Points Rules

Quick Reply To Top Return to the list