Please select To the mobile version | Continue to access the desktop computer version
View: 117|Reply: 4

How To Enable GT King Pro RS232 Serial Port

[Copy link]

4

Threads

332

Posts

1162

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
1162
Post time 2022-08-01 00:11:56 | Show all posts |Read mode
Edited by JFL at 2022-08-01 01:03

Hi Beelink Support,



I am trying to capture "boot log" using  "UGREEN 1.5m USB to RS232 DB9 Serial Female Converter Adapter Cable with PL2303 Chipset : https://www.lazada.com.my/products/ugreen-usb-to-db9-rs232-serial-female-adapter-cable-grey-creation-1mbps-transfer-for-windows-10-81-8-7-vista-xp-2000-linux-mac-os-x-macos-15m-i2104414411.html?spm=a2o4k.searchlist.list.113.25f65a85wPywrp" but somehow I get NO output from GT King Pro RS232.

Is there a setting/command or application to enable GT King Pro to output data from the RS232 port?

Is there any information on  the GT King Pro RS232 port pin out details?
Reply

Use magic Report

0

Threads

97

Posts

351

Credits

Super Moderator

Rank: 8Rank: 8

Credits
351
Post time 2022-08-04 20:13:34 | Show all posts
Could you please send us a picture of SN on the bottom of the machine ?
Reply Support Not support

Use magic Report

4

Threads

332

Posts

1162

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
1162
 Author| Post time 2022-08-04 23:58:14 | Show all posts
Support-03 replied at 2022-08-04 20:13
Could you please send us a picture of SN on the bottom of the machine ?

The serial number starts with SA9HH.

I am trying to capture the boot log using UART for troubleshooting purpose.  Actually wanting to send the log to @spikerguy (Manjaro Team).
Reply Support Not support

Use magic Report

0

Threads

97

Posts

351

Credits

Super Moderator

Rank: 8Rank: 8

Credits
351
Post time 7 day(s) ago | Show all posts
JFL replied at 2022-08-04 23:58
The serial number starts with SA9HH.

I am trying to capture the boot log using UART for troublesh ...

You need to set the correct port and Baud rate in the capture tool . Please find the link attached.  https://mega.nz/file/e89mmYTb#3B ... BdhZuIKKeF0GPJC_r4Y
Reply Support Not support

Use magic Report

4

Threads

332

Posts

1162

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
1162
 Author| Post time 7 day(s) ago | Show all posts
Edited by JFL at 2022-08-05 20:23
Support-03 replied at 2022-08-05 18:20
You need to set the correct port and Baud rate in the capture tool . Please find the link attached ...

Hi @support-03,

Thanks for the infromation (screen shot).

According to Device Manager the Port: COM3.  Do I need to set it to Port: COM48?
Baud rate: 115200
Datat bits: 8
Parity: None
Stop bits: 1

Serial break length: 5000 milliseconds (Not sure whether this setting is available on PuTTY)?

I did set the baud rate: 115200 before and NO output from GT King Pro RS232 port.  Will try it again.  Thank you.
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Sign up

Points Rules

Quick Reply To Top Return to the list