Please select To the mobile version | Continue to access the desktop computer version
Author: Chomee

Beelink GT1 bricked, please help

[Copy link]

2

Threads

39

Posts

130

Credits

Member

Rank: 2

Credits
130
Post time 2017-03-15 15:39:37 | Show all posts
@Chomee
Mine is a GT1 Ultimate but the stcok firmware is not available yet on the Intrnet...the stock firmware is 309MO...Someone should make a dump of it and , even better, Beelink could release it!
Reply Support Not support

Use magic Report

0

Threads

12

Posts

62

Credits

Member

Rank: 2

Credits
62
Post time 2017-03-15 17:15:23 | Show all posts
version  A912=FW6255 is correct?
version  G912=FW9377 is correct?
Reply Support Not support

Use magic Report

1

Threads

24

Posts

116

Credits

Member

Rank: 2

Credits
116
 Author| Post time 2017-03-15 19:59:20 | Show all posts
@Frank I don't have any more trust in Beelink customer service, so don't expect anything from then. They gave me wrong firmware, that's how I bricked mine GT1. Actually, they sent me 309 version for GT1 Ultimate, maybe you can try it. Contact me on skype and I will send you link for download.
@pepe666 It should be like that, but on mine box it was writen G912 but module was 6255. You won't know the truth 100% until you open your box and see what is written on wifi chip.
Reply Support Not support

Use magic Report

2

Threads

39

Posts

130

Credits

Member

Rank: 2

Credits
130
Post time 2017-03-15 22:57:04 | Show all posts
I found out what happened. Beelink sent me the wrong firmware. The firmware is based on your WiFi chip.

In fact my wifi chip is S/N A912 (AP6255 wifi chip)

and the gave me the rom for this one:

S/N S912 or G912 (AP9377 wifi chip)

They made a mess... I managed to reinstall everything using Beelink burning tool and a male to male usb cord
Reply Support Not support

Use magic Report

16

Threads

197

Posts

1187

Credits

Gold Member

Rank: 6Rank: 6

Credits
1187
Post time 2017-03-18 16:03:09 | Show all posts
Yes, you need to use the one USB OTG port with the Amlogic USB Burning Tool, which on the GT1 is the one on the side next to the microSD slot.
Reply Support Not support

Use magic Report

16

Threads

197

Posts

1187

Credits

Gold Member

Rank: 6Rank: 6

Credits
1187
Post time 2017-03-18 16:17:40 | Show all posts
Also, if your device isn't discovered in USB Burning Tool and you're sure you were ONLY connecting to the USB OTG connector while pressing the recessed button, it may mean that you have more serious problems (e.g. bad bootloader).  To fix this, you can open the unit and short pins on the eMMC chip to reset the NAND memory.  For my MXQ Pro it was pins 29&30 when I did this on Sunday, and it worked!  Only took about 20 minutes and most of that time was just figuring out which pins to short.
Reply Support Not support

Use magic Report

1

Threads

4

Posts

36

Credits

Newbie

Rank: 1

Credits
36
Post time 2017-03-19 02:41:32 | Show all posts
Hi all,

My GT1 Ultimate is dead during the update process. Windows is not able to detect the USB trough USB Burning Tool, the light on the box is on but nothing is detected.

I think is a bad bad bootloader.

Can anyone helpme with how to fix this?
Reply Support Not support

Use magic Report

2

Threads

39

Posts

130

Credits

Member

Rank: 2

Credits
130
Post time 2017-03-19 05:08:24 | Show all posts
Try to :1 run the tool, 2 connect the box to the Pc, 3 connect the power cord. In my case I didn't have to press the recessed button
Reply Support Not support

Use magic Report

1

Threads

4

Posts

36

Credits

Newbie

Rank: 1

Credits
36
Post time 2017-03-19 06:58:59 | Show all posts
This are the steps I'm doing:

0º Everything is disconected from the computer and also from the GT1
1º Start USB Burning Tool v2.0.8, set language to English.
2º Load the .img file, that on my case is "GT1_311M0.img" since I have the GT1 Ultimate Board q201_9377.
3º Go to File->Import Image and select the "GT1_311M0.img" to load. I get the Image check popup box.
4º I have the configuration on the USB Burning Tool set to: Erase Flash "X" - Force erase all, all the other check boxes are unpicked.
5º I press the start button on the USB Burning Tool software.
6º I plug the USB Cable A to A, on the side USB port from the GT1 Ultimate, and the LED comes ON.
7º I connect the power cord to the wall plug and to the GT1 Ultimate.
8º I plug the USB Cable A to A, to the USB 3.0 from the computer.

It is supposed to ear the windows sound but nothing happens.

I have tested many variations that I can remenber:
- Pressing and hold the reset button on the bottom of GT1 Ultimate with a paper clip before plug the power and USB.
- Withou pressing any button.
- Pressing and hold the reset button on the bottom of GT1 Ultimate with a paper clip after plug the power and USB.
- I have also tested around 6 versions of USB Burning Tool
- I also have tested all the list above but press the start button on the USB Burning Tool only at the end after everything pluged.

I did get once the GT1 Ultimate, recognized by the windows and USB Burning Tool, but when flashing I did get one error, after unplug and didn't get the windows to recognise the GT1 Ultimate any more.

Any ideas?
Reply Support Not support

Use magic Report

16

Threads

197

Posts

1187

Credits

Gold Member

Rank: 6Rank: 6

Credits
1187
Post time 2017-03-19 08:31:14 | Show all posts
Yes, you should wait on hitting Start in the USB Burning Tool until after you've successfully connected the box in recovery mode and get the "Connect success" message.  And to get in recovery mode, you'll definitely need to hold in the reset button with a paper clip as you connect the USB cable.  It should only take a few seconds.

If you're still not connecting, it's possible you've got a bad bootloader and need to reset the NAND.  See above instructions on shorting pins, but the procedure resurrected another Amlogic box for me just this week.
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Sign up

Points Rules

Quick Reply To Top Return to the list